Broken Console

You should be able to go to some directory and do the following.

   rails barf
   cd barf
   ruby script/console

Don't touch or edit any files or create any databases or anything.
Just do those three commands.

Do you still get the error?

Well we know the problem is with your Rails gems then. Since you're on
windows, it should be a fairly simple matter to blow away (or rename
away) c:\ruby and then grab the latest one-click installer and
reinstall. Then "gem install rails -y" should get you fixed up.

still a no go :frowning: I never seen the -y before, what is that supposed to
do? Is it the same as --include-dependencies? I uninstalled ruby and
rails completely, then downloaded the latest version and tried a brand
new fresh install.

I actually get this error on 3 different computers. The only thing I can
think of after dealing with this for so long is that there is some kind
of conflict with something I use.

How about eliminating script/console:

  C:\>rails barf
      ...snip...
      create log/development.log
      create log/test.log

  C:\>cd barf
  C:\barf>irb --simple-prompt
  >> require 'config/environment'
  => true
  >> RAILS_ENV
  => "development"