boolean field naming conventions

What you just described here is what I generally do. I have always liked to have boolean/bit values represented by some sort of question. is_approved, is_active, etc. Then in my model, I'd define a method approved?, active?, etc.

That's just me, though.

Peace,
Phillip