bj-1.0.0

(sorry for double post - subject got chopped on the last one)

NAME
   bj

SYNOPSIS
   bj (migration_code|generate_migration|migrate|setup|plugin|run|submit>list>set>config>pid) [options]+

HISTORY
   1.0.0:
     - use full path to ruby for plugin mode
     - plugin correctly installs bin -->> script
     - plugin install uses --force
     - properly quote paths in windows (spaces)
     - switch win signal to ABRT (was INT)
     - background job regrestration now uses ppid to pin the subprocess to a
       parent
     - use ppid to detect parent death and exit in event loop
     - don't use gem dependanices in plugin as they are broken when loading from
       muliple gem repos
     - added a small amount of drb magic that allows signals to work across
       processes even on windows (see http://drawohara.com/post/22540307)

DESCRIPTION

Tried to install this promising plugin on Windows XP, but I get the
following error message when running 'script/bj setup':

I, [..] INFO -- : cmd <C:/../ruby.exe ./script/generate migration
BjMigration0>
I, [..] INFO -- : status <0>
I, [..] INFO -- : generated <./db/migrate/042_bj_migration0.rb>
I, [..] INFO -- : cmd <rake RAILS_ENV=development db:migrate>
I, [..] INFO -- : status <42>
F, [..] FATAL -- : "rake RAILS_ENV=development db:
migrate" failed with #<Process::Status: pid=2684,exited(42)>
(RuntimeError)
C:/../vendor/plugins/bj/lib/bj/util.rb:28:in `spawn'
C:/../vendor/plugins/bj/lib/bj/api.rb:147:in `migrate'
C:/../vendor/plugins/bj/lib/bj/bj.rb:47:in `call'
C:/../vendor/plugins/bj/lib/bj/bj.rb:47:in `chroot'
C:/../vendor/plugins/bj/lib/bj/api.rb:146:in `migrate'
C:/../vendor/plugins/bj/lib/bj/api.rb:110:in `setup'
C:/../vendor/plugins/bj/lib/bj/bj.rb:54:in `call'
C:/../vendor/plugins/bj/lib/bj/bj.rb:54:in `chroot'
C:/../vendor/plugins/bj/lib/bj/bj.rb:52:in `chdir'
C:/../vendor/plugins/bj/lib/bj/bj.rb:52:in `chroot'
C:/../vendor/plugins/bj/lib/bj/api.rb:108:in `setup'
script/bj:349:in `run'
C:/../vendor/plugins/bj/lib/main/base.rb:25:in `call'
C:/../vendor/plugins/bj/lib/main/base.rb:25:in `run'
C:/../vendor/plugins/bj/lib/main/base.rb:13:in `catch'
C:/../vendor/plugins/bj/lib/main/base.rb:13:in `run'
C:/../vendor/plugins/bj/lib/main/base.rb:436:in `mode_run!'
C:/../vendor/plugins/bj/lib/main/base.rb:10:in `run'
C:/../vendor/plugins/bj/lib/main/factories.rb:11:in `run'
C:/../vendor/plugins/bj/lib/main/factories.rb:16:in `Main'
script/bj:6

Anyone know what could be wrong?

ruby 1.8.6 (2007-03-13 patchlevel 0)
Rails 2.0.2

Gerjan Stokkink wrote:

Updated Ruby, same error.

ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]

I have de same error with Windows XP

Any news