asset pipeline related error

I have this js file decimal.min.js which I put in the asset pipeline javascript directory. Whether I require it in the application.js manifest or not, I still get the error below. This is on windows in development mode … Any ideas or suggestions ? I find it slightly baffling … The js file itself does get served

ActionController::RoutingError (No route matches [GET] “/assets/doc/decimal.js.map”):
actionpack (4.2.2) lib/action_dispatch/middleware/debug_exceptions.rb:21:in all' web-console (2.2.1) lib/web_console/middleware.rb:39:incall’
actionpack (4.2.2) lib/action_dispatch/middleware/show_exceptions.rb:30:in c ll' railties (4.2.2) lib/rails/rack/logger.rb:38:in call_app’
railties (4.2.2) lib/rails/rack/logger.rb:20:in block in call' activesupport (4.2.2) lib/active_support/tagged_logging.rb:68:in block in ta
ged’
activesupport (4.2.2) lib/active_support/tagged_logging.rb:26:in tagged' activesupport (4.2.2) lib/active_support/tagged_logging.rb:68:in tagged’
railties (4.2.2) lib/rails/rack/logger.rb:20:in call' actionpack (4.2.2) lib/action_dispatch/middleware/request_id.rb:21:in call’
rack (1.6.4) lib/rack/methodoverride.rb:22:in call' rack (1.6.4) lib/rack/runtime.rb:18:in call’
activesupport (4.2.2) lib/active_support/cache/strategy/local_cache_middlewar
.rb:28:in call' rack (1.6.4) lib/rack/lock.rb:17:in call’
actionpack (4.2.2) lib/action_dispatch/middleware/static.rb:113:in call' rack (1.6.4) lib/rack/sendfile.rb:113:in call’
railties (4.2.2) lib/rails/engine.rb:518:in call' railties (4.2.2) lib/rails/application.rb:164:in call’
rack (1.6.4) lib/rack/content_length.rb:15:in call' thin (1.6.4) lib/thin/connection.rb:86:in block in pre_process’
thin (1.6.4) lib/thin/connection.rb:84:in catch' thin (1.6.4) lib/thin/connection.rb:84:in pre_process’
thin (1.6.4) lib/thin/connection.rb:53:in process' thin (1.6.4) lib/thin/connection.rb:39:in receive_data’
eventmachine (1.0.8) lib/eventmachine.rb:193:in run_machine' eventmachine (1.0.8) lib/eventmachine.rb:193:in run’
thin (1.6.4) lib/thin/backends/base.rb:73:in start' thin (1.6.4) lib/thin/server.rb:162:in start’
rack (1.6.4) lib/rack/handler/thin.rb:19:in run' rack (1.6.4) lib/rack/server.rb:286:in start’
railties (4.2.2) lib/rails/commands/server.rb:80:in start' railties (4.2.2) lib/rails/commands/commands_tasks.rb:80:in block in server’
railties (4.2.2) lib/rails/commands/commands_tasks.rb:75:in tap' railties (4.2.2) lib/rails/commands/commands_tasks.rb:75:in server’
railties (4.2.2) lib/rails/commands/commands_tasks.rb:39:in run_command!' railties (4.2.2) lib/rails/commands.rb:17:in <top (required)>’
bin/rails:4:in require' bin/rails:4:in

maybe I should not use a minified js file in the pipeline. I switched to a non minified version … so far no errors but sometimes it’s been intermittent