Amazon WS 3.0 Deprecation

Hello,

Not sure if this is the best place to ask but does anyone know of a Rail
plugin that works with the new Amazon ECS 4.0? Here is the deprecation
notice / migration guide

http://developer.amazonwebservices.com/connect/entry.jspa?categoryID=12&externalID=627

I've been using Ruby Amazon
(http://www.caliban.org/ruby/ruby-amazon.shtml) and Amazon email me
saying that they've noticed that my developer ID is still making 3.0
calls.

GP