ActiveJob test cases are failed

Hello, I have followed the Ruby on Rails contribution guide and set up a rails-dev-box environment. Everything was working until I tried to run the ActiveJob test suite and encountered 14 failed integration tests. All failed test messages all seem that the test helper method is not loaded correctly

NoMethodError: undefined method `adapter_is?' for #<QueuingTest:0x0000564d82945810>
    /vagrant/rails/activejob/test/integration/queuing_test.rb:126:in `block in <class:QueuingTest>'

Reproduce step:

cd activejob

Ruby version: 3.0.2

Thanks for your feedback

This should be fixed on main already. Thank you for reporting.

Hello, I’m getting this same error (running on a recently checked out version of rails ba19dbc49956a73f417abd68c7a5f33e302eacd3).

It seems like the tests that need adapter_is? can’t work unless the ENV var AJ_INTEGRATION_TESTS is set, but when I set that all the tests fail with an error like:

/src/rails/vendor/bundle/ruby/3.0.0/gems/zeitwerk-2.6.6/lib/zeitwerk/kernel.rb:38:in `require': cannot load such file -- /tmp/d20230322-144113-9wvgui/dummy/test/cases/argument_serialization_test.rb (LoadError)
        from /src/rails/vendor/bundle/ruby/3.0.0/gems/zeitwerk-2.6.6/lib/zeitwerk/kernel.rb:38:in `require'
        from /src/rails/railties/lib/rails/test_unit/runner.rb:50:in `block in load_tests'
        from /src/rails/railties/lib/rails/test_unit/runner.rb:50:in `each'
        from /src/rails/railties/lib/rails/test_unit/runner.rb:50:in `load_tests'
        from /src/rails/railties/lib/rails/test_unit/runner.rb:42:in `run'
        from /src/rails/tools/test.rb:18:in `<top (required)>'
        from bin/test:5:in `require_relative'
        from bin/test:5:in `<main>'

(that “dummy” directory is populated with files, but they’re not from activejob afaict).