Access denied for user 'root'@'localhost'

I am getting error
Access denied for user 'root'@'localhost' (using password: NO)

i saw in database.yaml
Install MySQL and put its /bin directory on your path.
how to set it

Attachments:
http://www.ruby-forum.com/attachment/1828/database.yml

Manika Suri wrote:

I am getting error
Access denied for user 'root'@'localhost' (using password: NO)

i saw in database.yaml
Install MySQL and put its /bin directory on your path.
how to set it

Example app_name/config/database.yml :

development:
  adapter: mysql
  database: teapoci_development
  username: root
  password:
  host: localhost

make sure that your database login in mysql is correct, like password or
username.

Manika Suri wrote:

I am getting error
Access denied for user 'root'@'localhost' (using password: NO)

i saw in database.yaml
Install MySQL and put its /bin directory on your path.
how to set it

You may also have to log on to MySQl as root with -P option and GRANT
permission for root to access the database.