In our public API, we use a UUID for record identifiers, however our primary key internally is the default incrementing integer in Postgres. I’d like to submit a PR that adds an option to
accepts_nested_attributes_for that would change which key is being queried on, but doesn’t require a change of
primary_key in the model.
Would this get accepted? If so, I’m interested in opinions on a good name for the option. Could be as simple as
:primary_key, similar to how
belongs_to has an option for
:primary_key which does not require a primary key change in the associated model.