Wrong action names

Is there somewhere a list of names that should not be used as action names ?

I recently created an action named “load” and it disappeared from inherited controller.

Would such a list be equal to : AbstractController::Base.internal_methods ?

Robert Pankowecki


Well, load is a Ruby instruction. I would steer away from using things like 'load', 'require', etc. for method names even though they are not specifically mentioned as reserved. A old list or reservations can be found here:


and Rails stuff, also old, can be found here: