Windows, Rails 3.1.3, Omniauth-BrowserID, SSL Erro

One and all, I have scoured the internet high and low tonight and I
can not for the life of me fix this damn problem. I have downloaded
certificates, installed certificates, changed my :ca_path and such as
stated in the documentation for omniauth-facebook for which I thought
would be ok to do with this one. Can anyone point me in the right
direction of how to disable SSL in development mode (I'm still quite a
novice so would appreciate a little bit of simple chat. Is there
something I can put in my environment file to help? the error I am
having is;

SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B:
certificate verify failed

I've had it before and fixed it by downloading certificates and
setting the path but that was using omniauth-facebook and on linux.
Please don't tell me to use linux, its not possible right now.

This is all, thanks in advance. Have a good day.

Toodle pip

Same as covered here for Mechanize:

http://stackoverflow.com/questions/8567973/why-does-accessing-a-ssl-site-with-mechanize-on-windows-fail-but-on-mac-work/8568915#8568915

Applies to OmniAuth (0.2.6 and Rails 2.3.14 in this example)

ca_file = File.expand_path Rails.root.join("config", "cacert.pem")

ssl_options = {}
ssl_options[:ca_path] = '/etc/ssl/certs' if Rails.env.staging?
ssl_options[:ca_file] = ca_file

ActionController::Dispatcher.middleware.use OmniAuth::Builder do
  provider :facebook, $omniauth[:facebook_app_id],
$omniauth[:facebook_app_secret],
    :scope => $omniauth[:facebook_scope],
    :client_options => { :ssl => ssl_options }
end

The principle is the same for newer version of OmniAuth. You just need
the cert bundle.