will_paginate appending escape=false to every page URL?

It's visually annoying to see every URL with escape=false appended to
it. It doesn't even makes sense, disabling the escaping through a GET
parameter? What?

How do I disable it so the pages show up like ?page=1, instead of
?page=1&escape=false ? -.-

It's visually annoying to see every URL with escape=false appended to
it. It doesn't even makes sense, disabling the escaping through a GET
parameter? What?

I've never seen that before. How are you invoking will_paginate?

Fred

That might be a bug with older versions. For Rails 3, use will_paginate 3.0.pre4 or later:

gem “will_paginate”, “~> 3.0.pre4”

Mislav MarohniÄ? wrote in post #1015695:

That might be a bug with older versions. For Rails 3, use will_paginate
3.0.pre4 or later:

  gem "will_paginate", "~> 3.0.pre4"

Darn, I feel stupid for not trying that first, thanks haha

Also, look closely at Kaminari for a nice replacement. I haven't tried Will Paginate on 3, not since I found Kaminari.

Walter

Walter Davis wrote in post #1015942: