WHy is rails so annoying to deploy?

Yeah freaking with "NOTHING WORKS!!!!!!!!!" isn't really the best
approach when... trying to do anything. Regardless, having never heard
of xlsuite before your post, I figured I'd try to get it running to
try to see where things might go have gone wrong.

First, ran git clone git://github.com/xlsuite/xlsuite.git. Then, as
you mentioned the "ActionController::AbstractRequest (NameError)"
error, I tried to find out from their site what version of Rails it
requires. Apparently doesn't matter, as they've frozen Rails with
their app, so it will always use the bundled version rather than
whatever you happen to have installed via RubyGems. Next, I followed
the instructions in the INSTALL file:

= Basic Installation

XLsuite is built on-top of MySQL and cannot currently use any other
database servers.

1. cp config/database.yml.sample config/database.yml
2. Edit config/database.yml to suit you (must use MySQL)
3. rake db:create db:structure:load db:bootstrap
4. script/server
5. http://localhost:3000/

= Complete Installation

You will need to register an account at Amazon's Web Services to use
the Simple Storage Service (S3). XLsuite stores it's assets in S3.
You may configure Asset to store the files on the local filesystem by
changing the :storage key of the #has_attachment call to :file_system.

If you want to integrate with Google Maps, you'll need a Google Maps
API key. Update the Configuration named :google_maps_api_key with
your key.

= Running the tests

1. rake db:create RAILS_ENV=test
2. rake

After creating my database user and configuring database.yml
accordingly, I ran "rake db:structure:load db:bootstrap" (as I don't
give my development roles SUPER privileges." I *did* get an error here
though:

(in /home/xeno/projects/
xlsuite)
Missing these required
gems:
  RedCloth ~>
4.0

You're running:
  ruby 1.8.7.72 at /usr/bin/ruby1.8
  rubygems 1.3.5 at /home/xeno/.gem/ruby/1.8, /usr/lib/ruby/gems/1.8

Run `rake gems:install` to install the missing gems.

So I ran sudo rake gems:install (again, I'm not running as the
superuser). RedCloth installed successfully, as did the database rake
commands now. Then I ran ./script/server, browsed to http://localhost:3000,
and after waiting for whatever it is XLSuite does, was greeted with
the login page.
a
Relevant information for my environment is:

xeno@Clover:~/projects/xlsuite$ cat /etc/issue
Ubuntu 9.04 \n \l

xeno@Clover:~/projects/xlsuite$ ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [x86_64-linux]

Using the distro's Ruby, not anything custom compiled here. So,
before trying to hack away for no reason at code you do not
understand, what *are* the errors you're encountering, and what are
you doing to resolve each individual error as it happens?