what it needs to be done to upgrade to 2.0???

Hi,

I had to left my project for some time to take care of some other
stuff last December, i was using 1.2.5, everything works just fine
then.

when i tried to pick up my project and give 2.0 a try, everything
seems to fall apart and stop running.

first, i solve the OpenID warning
then, the action_mailer warning

after this there was this "500 internal server error" problem, no
matter what url i put in. after i've doen some research on google, i
add "config.action_controller.session = { :session_key =>
"_myapp_session", :secret =>"write smth here with at least 30
characters" }" in my environment.rb, the problem is gone

but things aren't just that easy, now the problems are just
everywhere. for example, i've got message like:
The :dependent option expects either :destroy, :delete_all,
or :nullify (true)

c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/
associations.rb:1149:in `configure_dependency_for_has_many'
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/
associations.rb:669:in `has_many'
vendor/plugins/acts_as_rateable/lib/acts_as_rateable.rb:12:in
`acts_as_rateable'

my project isn't really a RESTful design, is there something to do
with this? do i declare "has_many" relationship diferently on 2.0?

what exactly needs to be done to upgrade to rails 2.0? is there a
list? why did it make it so hard to upgrade??

thanks.

but things aren't just that easy, now the problems are just
everywhere. for example, i've got message like:
The :dependent option expects either :destroy, :delete_all,
or :nullify (true)

c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/
associations.rb:1149:in `configure_dependency_for_has_many'
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/
associations.rb:669:in `has_many'
vendor/plugins/acts_as_rateable/lib/acts_as_rateable.rb:12:in
`acts_as_rateable'

my project isn't really a RESTful design, is there something to do
with this? do i declare "has_many" relationship diferently on 2.0?

Kind of what it says: you used to be able to say :dependant => true, but not any more. It looks like thats happening inside the acts as rateable plugin so I'd check that you've got the latest version of that.

what exactly needs to be done to upgrade to rails 2.0? is there a
list? why did it make it so hard to upgrade??

It was very smooth for me. However they key to that was having really good test coverage and then bashing every deprecation warning that showed up in the test logs. Plugins are also vulnerable, because they often monkey patch internals which are liable to change at the drop of a hat.

Fred