Vimeo API Error.

I am working on an Application which requires Vimeo API. I have done
that on separate application but when i am trying to get that thing on
actual project it doesn't work. I have followed this .

http://github.com/matthooks/vimeo

for getting this up.

The error comes when I add config.gem "vimeo" into environment.rb.
where as
[Awijeet@localhost loc]$ gem list -l

vimeo (1.2.2)

error comes as below.

script/server
=> Booting WEBrick
=> Rails 2.3.8 application starting on http://0.0.0.0:3000
Rails Error: Unable to access log file. Please ensure that
/home/Awijeet/railsaps/loc/log/development.log exists and is chmod 0666.
The log level has been raised to WARN and the output directed to STDERR
until the problem is fixed.
Dispatcher: webrick
Application: LOC
Agent configured not to send data in this environment - edit
newrelic.yml to change this
New Relic RPM Agent 2.13.1 Initialized: pid = 4384
Agent Log found in /home/Awijeet/railsaps/loc/log/newrelic_agent.log
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:19:
warning: already initialized constant OK
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:20:
warning: already initialized constant CREATED
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:21:
warning: already initialized constant ACCEPTED
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:22:
warning: already initialized constant NON_AUTHORITATIVE_INFORMATION
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:23:
warning: already initialized constant NO_CONTENT
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:24:
warning: already initialized constant RESET_CONTENT
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:25:
warning: already initialized constant PARTIAL_CONTENT
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:26:
warning: already initialized constant MOVED_PERMANENTLY
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:27:
warning: already initialized constant FOUND
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:28:
warning: already initialized constant SEE_OTHER
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:29:
warning: already initialized constant MOVED_TEMPORARILY
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:29:
warning: already initialized constant TEMPORARY_REDIRECT
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:30:
warning: already initialized constant BAD_REQUEST
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:31:
warning: already initialized constant UNAUTHORIZED
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:32:
warning: already initialized constant PROXY_AUTHENTICATE_REQUIRED
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:33:
warning: already initialized constant INTERNAL
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:94:
warning: already initialized constant CRLF
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:618:in
`private': undefined method `new' for class `Class' (NameError)
  from
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/http.rb:618
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient/session.rb:19
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/httpclient-2.1.5.2/lib/httpclient.rb:17
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/vimeo-1.2.2/lib/vimeo/advanced/upload.rb:1
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/vimeo-1.2.2/lib/vimeo/advanced.rb:11
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from /usr/local/lib/ruby/gems/1.8/gems/vimeo-1.2.2/lib/vimeo.rb:7
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/gem_dependency.rb:215:in
`load'
  from
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:307:in
`load_gems'
  from
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:307:in
`each'
  from
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:307:in
`load_gems'
  from
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:164:in
`process'
  from
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:113:in
`send'
  from
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:113:in
`run'
  from /home/Awijeet/railsaps/loc/config/environment.rb:5
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/commands/server.rb:84
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from script/server:3

Thanks in Adv.