Upgrade to 2.2.2 - problem with existing Localization library

I upgraded my application to Rails 2.2.2 from 1.2.6 last night.

I encountered a problem with the Localization library (1.0.7) that I
installed at the time of installing SaltedHashLoginGenerator (requires
Localization). Error message below. Error occurs when I fire up
WeBrick.

Is there a new localization feature in Rails 2 that is causing a
problem?

Thanks!

yes there is. but it's not (only) causing problems, but adding a
translation feature. imho it's actually nice to have.

check out railscasts to learn more about i18n:
http://railscasts.com/episodes/138-i18n