undefined method `name' for “SystemTimer”:String

Hey All,

I am having a problem getting an old Ruby on Rails 2 app that hasn't
worked in a year to work.

I'm trying to run rake test:functionals in the root of my project
directory but am getting undefined method `name' for

I've pasted everything that I believe relevant to the problem here:

Also, when I run rake itself, I get Errors running test:units! Not sure
how to debug that.

I have copied and pasted everything that I think would be useful to
understanding this problem. Your time is greatly appreciated. Thank you.

I noticed that you’ve got rails vendored. Even though you list the gems on your system, I can’t know for sure what version of ruby you’re running on since its running on the vendored version. Either tell us what all you’ve got vendored or just un-vendor rails and run it off your system.

I personally recommend migrating to using bundler. You can use this guide to set it up for a rails 2.3 app (if it is 2.3.x):


Either way, it looks like you’ve got an old version of rails interacting w/a very new version or rubygems. Not sure though. Let us know what’s in vendor/