Unable to install rubygems

Hi,

I have got ruby and rails installed on my machine. however i am having trouble installing ruby gems. It get a missing method error. A method named path is missing in Gem.

Any ideas as to why this might happen?

I have run through many install-uninstall cycles. I was wondering if there is a way to do a full uninstall and a fresh install of ruby and rails?

Thanks, Shashank

For anyone to have any hope of helping, you need to tell us which Operating System you are using (Ubuntu, XP, etc) and exactly how you tried to install whatever it is that you are trying to install and exactly what the error is.

Also tell us which versions of Ruby and Rails you are using.

Colin

Shashank wrote in post #974876:

I have got ruby and rails installed on my machine. however i am having trouble installing ruby gems. It get a missing method error. A method named path is missing in Gem.

Any ideas as to why this might happen?

I have run through many install-uninstall cycles. I was wondering if there is a way to do a full uninstall and a fresh install of ruby and rails?

This is a complete shot-in-the-dark, but are you trying to use RubyGems 1.4.1 with Ruby 1.9.2?

If this is the case check out:

http://ruby5.envylabs.com/episodes/141-episode-138-january-4-2011

"Just before the end of the year, the RubyGems team bestowed version 1.4.0 and 1.4.1 upon us. With it, though, came a very ominous, "DO NOT UPGRADE IN RUBY 1.9," message. So, please heed their advice. Upgrade in Ruby 1.8, if you like, but unless you detest kittens, do not upgrade in Ruby 1.9."