trying to install edge rails and...

executing:

rake rails:freeze:edge TAG=rel_1-2-0_RC2

and getting error:

"ERROR: Must have subversion (svn) available in the PATH to lock this
application to edge rails"

I don't have an SVN client installed, and am generally not familiar
with it. Can someone point me in the right direction?

Thanks so much in advance!

Mike

http://subversion.tigris.org/

Gregg:

Thanks for your reply. I installed an SVN client but I'm still getting
the same error. Do I need to put something in my PATH?

Thanks!

Mike

Update: tried installing to my path in windows, but still not being
recongized. Is there another way?

Ok, assuming you have installed svn, make sure your environment
variable PATH includes this:
C:\Program Files\Subversion\bin

Here's my full PATH variable value:
c:\ruby\bin;%SystemRoot%\system32;%SystemRoot%;C:\Program
Files\Subversion\bin

You can edit your PATH variable by going to My
Computer->Properties->Advanced->Environment Variables -- you'll want
to look under 'System Variables', there you'll find PATH

Then run your rake command.