Testing problems: ActiveSupport

Hey everybody,

I am trying to test a small application with a simple testing, but I get
the following errors while using Aptana 2.0.5 with Ruby 1.9.1 and Rails
2.3.8(I know why I get the first one, but I'm not sure about the
ActiveSupport errors):

Exception: undefined method `screen_name' for nil:NilClass
C:/Ruby191/lib/ruby/gems/1.9.1/gems/activesupport-2.3.8/lib/active_support/whiny_nil.rb:52:in
`method_missing'
D:/Projects/RailsSpace/test/functional/user_controller_test.rb:39:in
`try_to_login'
D:/Projects/RailsSpace/test/functional/user_controller_test.rb:28:in
`testing_logout'
C:/Ruby191/lib/ruby/gems/1.9.1/gems/activesupport-2.3.8/lib/active_support/testing/setup_and_teardown.rb:62:in
`run'
C:/Ruby191/lib/ruby/gems/1.9.1/gems/test-unit-2.1.0/lib/test/unit/testsuite.rb:38:in
`block in run'
C:/Ruby191/lib/ruby/gems/1.9.1/gems/test-unit-2.1.0/lib/test/unit/testsuite.rb:37:in
`each'
C:/Ruby191/lib/ruby/gems/1.9.1/gems/test-unit-2.1.0/lib/test/unit/testsuite.rb:37:in
`run'
C:/Ruby191/lib/ruby/gems/1.9.1/gems/test-unit-2.1.0/lib/test/unit/testsuite.rb:38:in
`block in run'
C:/Ruby191/lib/ruby/gems/1.9.1/gems/test-unit-2.1.0/lib/test/unit/testsuite.rb:37:in
`each'
C:/Ruby191/lib/ruby/gems/1.9.1/gems/test-unit-2.1.0/lib/test/unit/testsuite.rb:37:in
`run'
C:/Ruby191/lib/ruby/gems/1.9.1/gems/test-unit-2.1.0/lib/test/unit/ui/testrunnermediator.rb:48:in
`run_suite'
D:/Projects/.metadata/.plugins/org.rubypeople.rdt.testunit/ruby/RemoteTestRunner.rb:117:in
`start_mediator'
D:/Projects/.metadata/.plugins/org.rubypeople.rdt.testunit/ruby/RemoteTestRunner.rb:62:in
`start'
D:/Projects/.metadata/.plugins/org.rubypeople.rdt.testunit/ruby/RemoteTestRunner.rb:332:in
`<main>'

Thanks a lot to everybody in advance!