submit() not working on first click....it is working on second click

I am developing an e-commerce site… and now I got stuck at one point… When I submit the form ,it doesn’t submits on the first click ,
and i need to give a second click to get it working… I have used anchor tag to submit my data bcoz I want to show the data inside thickbox(iframe)…

  View file
  <%= form_for :order, :url => populate_orders_url ,:html => { :class => "data# [product.id](http://product.id)}"},:method => "post",:remote => true do |f| %>

 // data
//submit button

    <a href="/cart?KeepThis=true&TB_iframe=true&height=380&width=1000&modal=false"  onclick="$('.data<%= [product.id](http://product.id) %>').submit().trigger.reload();"   class="thickbox cart_button"></a>

 orders controller.rb
 def populate
  @order = current_order(true)

  params[:products].each do |product_id,variant_id|

    quantity = params[:quantity].to_i if !params[:quantity].is_a?(Hash)

    quantity = params[:quantity][variant_id].to_i if params[:quantity].is_a?(Hash)

    @order.add_variant(Variant.find(variant_id), quantity, ad_hoc_option_value_ids, product_customizations) if quantity > 0

  end if params[:products]

  params[:variants].each do |variant_id, quantity|

    quantity = quantity.to_i
    @order.add_variant(Variant.find(variant_id), quantity, ad_hoc_option_value_ids, product_customizations) if quantity > 0

  end if params[:variants]

  fire_event('spree.cart.add')
  fire_event('spree.order.contents_changed')

  redirect_to cart

end

I have seen in firebug and populate method is processed but it not sending data into cart and it showing me empty cart…and cart is processing…

Please help…!!

Have a look in development.log and see what is added when you click it
the first time. You will see what action, if any, is run. Then have
a look at the Rails Guide on Debugging to see methods that are useful
for debugging the code.

Colin

that all I have done…I am not getting anything in development log…
Any other suggestion??

I mean, product id is passed… but its not showing me cart page…

I mean, product id is passed... but its not showing me cart page...

So when you click the button the first time you see it calling an
action in the log, but that action is not doing what you expect? In
that case, as I said before, have a look at the Rails Guide on
debugging to find how to debug the code. Put debug display code in
the action or use the debugger to find why it is going wrong.

Colin

Actually I have now install foot note gem in my development mode… Here what I am getting is that, data is inserted into cart, but it is not showing me in thick box (localhost:3000) as my thick box pop-ups at my home page… It is showing me in localhost:3000/cart… Its actual link…

<a **href****="/cart?KeepThis=true&TB_iframe=true&height=380&width=1000&modal=false"**  onclick="$('.data<%= [product.id](http://product.id/) %>').submit().trigger.reload();"   class="thickbox cart_button"></a>

problem lies here… but whats other alternative… I have used link_to tag… ??

I have used link_to tag already… and button tag also… my major requirement is that I need to show them in thickbox…

can I reload thickbox automatically???

can I reload thickbox automatically???

I have no idea even what thickbox is, sorry.

Colin