Strange bug using runt with rails

Hi all,

I'm trying to include the 'runt' gem (http://runt.rubyforge.org/) in my Rails project. I've tried a few ways of doing this. I've tried installing runt using 'gem install runt' and then trying to do "require 'runt'" in my environment.rb, and I've also tried using the 'vendor everything' method (described at Vendor Everything — err.the_blog).

In both cases, when I put "require 'runt'" into my environment.rb file, start up webrick, and try to load a page from my app in the browser, the ruby process jumps up to 100%, the page never loads, and I have to kill the server. I get no error messages on the console or in development.log. I am able to "require 'runt'" in a standard ruby script or in irb just fine, and I've gotten this error on two different machines with different environments.

I am using Rails 2.0.2, ruby 1.8.6, and runt 0.6. I'm sort of stuck, so if anyone has any ideas about either how to fix this or simply how to get more debugging info our of rails, I would be very appreciative.

Thanks so much, Ben

Hi Ben

Did you ever find a solution to this, I am having the same issue.

Thanks Toby