Strange behavior with lighttpd

I got this strange problem with my Rails app here in lighttpd… sometimes it appears and sometimes it doesn’t. When it does appear, and I try to refresh it from Firefox, it won’t appear until I clear my cache.

Huh?

lighttpd_error.log says “(response.c.467) Path: /services/httpd/mysite.com/www/public/dispatch.fcgi – file found” which is strange, because the file is there, and if it was a permission problem it probably wouldn’t display at all.

Here is my configuration:

server.modules = ( “mod_access”, “mod_accesslog”, “mod_rewrite”, “mod_redirect”, “mod_fastcgi” )
server.document-root = “/usr/local/www”
server.errorlog = “/var/log/lighttpd_error.log”

debug.log-request-handling = “enable”

index-file.names = ( “index.html” )

mimetype.assign = (
“.pdf” => “application/pdf”,
“.sig” => “application/pgp-signature”,
“.spl” => “application/futuresplash”,
“.class” => “application/octet-stream”,
“.ps” => “application/postscript”,
“.torrent” => “application/x-bittorrent”,
“.dvi” => “application/x-dvi”,
“.gz” => “application/x-gzip”,
“.pac” => “application/x-ns-proxy-autoconfig”,
“.swf” => “application/x-shockwave-flash”,
“.tar.gz” => “application/x-tgz”,
“.tgz” => “application/x-tgz”,
“.tar” => “application/x-tar”,
“.zip” => “application/zip”,
“.mp3” => “audio/mpeg”,
“.m3u” => “audio/x-mpegurl”,
“.wma” => “audio/x-ms-wma”,
“.wax” => “audio/x-ms-wax”,
“.ogg” => “application/ogg”,
“.wav” => “audio/x-wav”,
“.gif” => “image/gif”,
“.jpg” => “image/jpeg”,
“.jpeg” => “image/jpeg”,
“.png” => “image/png”,
“.xbm” => “image/x-xbitmap”,
“.xpm” => “image/x-xpixmap”,
“.xwd” => “image/x-xwindowdump”,
“.css” => “text/css”,
“.html” => “text/html”,
“.htm” => “text/html”,
“.js” => “text/javascript”,
“.asc” => “text/plain”,
“.c” => “text/plain”,
“.cpp” => “text/plain”,
“.log” => “text/plain”,
“.conf” => “text/plain”,
“.text” => “text/plain”,
“.txt” => “text/plain”,
“.dtd” => “text/xml”,
“.xml” => “text/xml”,
“.mpeg” => “video/mpeg”,
“.mpg” => “video/mpeg”,
“.mov” => “video/quicktime”,
“.qt” => “video/quicktime”,
“.avi” => “video/x-msvideo”,
“.asf” => “video/x-ms-asf”,
“.asx” => “video/x-ms-asf”,
“.wmv” => “video/x-ms-wmv”,
“.bz2” => “application/x-bzip”,
“.tbz” => “application/x-bzip-compressed-tar”,
“.tar.bz2” => “application/x-bzip-compressed-tar”
)

url.access-deny = ( “~”, “.inc” )

$HTTP[“url”] =~ “.pdf$” { server.range-requests = “disable” }

server.error-handler-404 = “/error-handler.html”

server.pid-file = “/var/run/lighttpd.pid”

$HTTP[“host”] =~ “.mysite.com” {

server.document-root = "/services/httpd/mysite.com/www/public"
accesslog.filename = "/services/httpd/mysite.com/logs/access.log"
fastcgi.server = ( ".fcgi" => ( "mysite" => ("socket" => "/services/httpd/mysite.com/www/mysite.socket", "bin-path" => "/services/httpd/mysite.com/www/public/dispatch.fcgi")))
server.indexfiles = ( "index.html" )
server.error-handler-404 = "/dispatch.fcgi"

}

Thanks.

Kyrre Nygaard