ssl - browser warning on IE - page contains both secure a

do a view-source and make sure you’re not linking to any files on the http:// protocol. like JS, CSS or image files.


I ran into the same issue after adding Google anaytics to my pages. What I ended up doing was to use and if statement in the view to only output the google analytics for pages that I want to allow it (which are most my unsecure pages).

That can be as simple as

<%= if @allow_google_analytics %>

google stuff here

<% end -%>

and then in your controller just put a before_filter to call a method to set the variable when you will want google_analytics.

so you might have something like

before_filter :allow_google_analytics


def allow_google_analytics   @allow_google_analytics = true end

As for switching to https from your pages, you can simply use https in a url or if you are using link_to/url_for helpers then there is a :protocol option to allow you to change it.

There also is a plugin called ssl_requirement that can be used to automatically insure you are secure and will redirect if they aren't. Depending on your needs this may help as well.


put a link to download firefox on your page so users get a real browser!

While I agree that everyone should be using Firefox, the issue exists in both browsers. In Firefix you will get an indication that part of the page is insecure as well, which is a good thing.