sqlite3-ruby is invalid?

Hello
I have been learning ruby on rails 3 from the Michael hartl book, and
I have run into something that I can't figure out. After updating the
gem file and running bundle install, I am getting the following error

You passed :required as an option for gem 'sqlite3-ruby', but it is
invalid.

Here is the gem file code. Below this is what I added. Can anyone
tell me why I am getting this error?

Thanks

source 'https://rubygems.org'

gem 'rails', '3.2.0'
gem 'sqlite3-ruby', '1.2.5', :required => 'sqlite3'

group :development do
  gem 'rspec-rails', '2.0.1'
end

group :test do
  gem 'rspec', '2.0.1'
  gem 'webrat', '0.7.1'
end

# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails.git'

gem 'sqlite3'

# Gems used only for assets and not required
# in production environments by default.

Here is the stuff I added

gem 'sqlite3-ruby', '1.2.5', :required => 'sqlite3'

group :development do
  gem 'rspec-rails', '2.0.1'
end

group :test do
  gem 'rspec', '2.0.1'
  gem 'webrat', '0.7.1'
end

Hello
I have been learning ruby on rails 3 from the Michael hartl book, and
I have run into something that I can't figure out. After updating the
gem file and running bundle install, I am getting the following error

You passed :required as an option for gem 'sqlite3-ruby', but it is
invalid.

Here is the gem file code. Below this is what I added. Can anyone
tell me why I am getting this error?

Thanks

source 'https://rubygems.org'

gem 'rails', '3.2.0'
gem 'sqlite3-ruby', '1.2.5', :required => 'sqlite3'

group :development do
  gem 'rspec-rails', '2.0.1'
end

group :test do
  gem 'rspec', '2.0.1'
  gem 'webrat', '0.7.1'
end

# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails.git'

gem 'sqlite3'

# Gems used only for assets and not required
# in production environments by default.

Here is the stuff I added

gem 'sqlite3-ruby', '1.2.5', :required => 'sqlite3'

make that :require not :required and this should work.

Walter

Bundler syntax:

gem “name”, “version”, :require => “path/to/require”

See Bundler documentation:

http://gembundler.com/man/gemfile.5.html

In relation to SQLite3 gem, gem is now “sqlite3”, sqlite3-ruby is now a shim/redirect and has been deprecated.

So, you will end with this in your Gemfile:

gem “sqlite3”, “~> 1.3.5”

There is no need for :require since the gem name matches the require itself.

Thank up Walter.

Think I looked at that line a hundred times. I know it had to work -
it work all along.
Thanks again
Jeff