sqlite3 installation problem

After installing sqlite3 using command line I face this problem in
application environment;

RuntimeError in Rails/infoController#properties

unknown error
RAILS_ROOT: C:/Users/User/project_home
Application Trace | Framework Trace | Full Trace
This error occurred while loading the following files:
   sqlite3/driver/dl/driver
   sqlite3/driver/dl/api

Anyone here has managed this?

Robert Jefferson wrote:

After installing sqlite3 using command line I face this problem in
application environment;

RuntimeError in Rails/infoController#properties

unknown error
RAILS_ROOT: C:/Users/User/project_home
Application Trace | Framework Trace | Full Trace
This error occurred while loading the following files:
   sqlite3/driver/dl/driver
   sqlite3/driver/dl/api

Anyone here has managed this?

Hi Robert,

I am also getting the same problem when I try to access the applicaton
URL. Did you find a solution to your problem. If yes can you please let
me know the same.

Regards,
Jyo

Thanks Rob.
I installed the gems but did not update the dll file. I did that and it
worked fine :).

Thanks for your help.
Now I have a new problem:
When I try to run the following program I get a segmentation fault:
require 'rubygems'
require 'json'
require 'net/http'
def testrsv()
   base_url =
"http://10.221.112.10:8080/reserve-online/reservations?status=emailed&format=json"
   url = "#{base_url}"
   resp = Net::HTTP.get_response(URI.parse(base_url))
   data = resp.body
   # data structure - a hash
   result = JSON.parse(data)
   # if the hash has 'Error' as a key, we raise an error
   result['reservations']['reservation'].each { |result|
   print "#{result['ean']} => #{result['status']}\n"
   }

end

C:/Users/SudJyo/AppData/Local/Temp/rb276D.tmp:21: [BUG] Segmentation
fault
ruby 1.8.6 (2007-09-24) [i386-mswin32]

This application has requested the Runtime to terminate it in an unusual
way.
Please contact the application's support team for more information.

Can you help me finding the cause of this issue?

Thanks,
Jyo

Have you installed the rubygems? I'm not sure of your problems, I didn't
encounter those.

If I were you, I'd try updating the rubygems. Sorry that's so far I can
think of at the moment.

Robert Jefferson wrote:

Have you installed the rubygems? I'm not sure of your problems, I didn't
encounter those.

If I were you, I'd try updating the rubygems. Sorry that's so far I can
think of at the moment.

Thanks Rob.

Jyo Ni wrote:

Robert Jefferson wrote:

Have you installed the rubygems? I'm not sure of your problems, I didn't
encounter those.

If I were you, I'd try updating the rubygems. Sorry that's so far I can
think of at the moment.

Thanks Rob.

No problem at all, wish I could help more. Anyway my advice is try to
tackle one-by-one. You'd solve all, don't worry. :slight_smile:

Good Luck and remember to have fun along rubying...

:slight_smile: