[Slightly-OT] RailsConf Video problem

Anyone else tried downloading the RailsConf videos from http://blog.scribestudio.com/pages/rails/ ?
I think it’s a bit weird that they posted it in Mac-centric format (.sitx), but I can’t complain since they’re giving them out for free. What I am a bit stumped on is opening the files. I’ve downloaded them to both my Linux box and Powerbook and tried Unstuffing them - no luck. I get a “Format Error #17540” everytime.

Anyone have the same problem? Is it just me?

I can't open sitx on my PowerBook, either. I believe that is because sitx is a proprietary format created by the commercial version of Stuffit. I would expect only a very small proportion of current MacOS X users would be willing to use Stuffit, it's heyday was way back on MacOS 7.

Paul

Weird. It looks like Stuffit knows how to open them, but then errors at the end of the process. Either way, it’s still odd that they compressed them in that format. Maybe I’ll email the site owners…unless they’re watching this list!?