Setting up omniauth with salesforce login in rails 2.3.8( ruby 1.8.6)

Hi,

We have a production rails app running on ruby 1.8.6 with rails version 2.3.8.
We are thinking about setting up omniauth to allow users login through salesforce.
But the omaniauth ldap dependency inturn depends on ruby 1.8.7.

Is there any way we can setup ominauth without ldap dependency to work on
ruby 1.8.6?