Server won't start on using authlogic-oauth2

I have included oauth2 and authlogic-oauth2 in the gemfile as I want to
use them and am trying to start the server. It doesn't start and gives
me the error

/Library/Ruby/Gems/1.8/gems/railties-3.0.3/lib/rails.rb:44:in
`configuration': undefined method `config' for nil:NilClass
(NoMethodError)
        from
/Library/Ruby/Gems/1.8/gems/authlogic_oauth2-1.1.2/lib/authlogic_oauth2.rb:14
        from
/Library/Ruby/Gems/1.8/gems/bundler-1.0.7/lib/bundler/runtime.rb:64:in
`require'
        from
/Library/Ruby/Gems/1.8/gems/bundler-1.0.7/lib/bundler/runtime.rb:64:in
`require'
        from
/Library/Ruby/Gems/1.8/gems/bundler-1.0.7/lib/bundler/runtime.rb:62:in
`each'
        from
/Library/Ruby/Gems/1.8/gems/bundler-1.0.7/lib/bundler/runtime.rb:62:in
`require'
        from
/Library/Ruby/Gems/1.8/gems/bundler-1.0.7/lib/bundler/runtime.rb:51:in
`each'
        from
/Library/Ruby/Gems/1.8/gems/bundler-1.0.7/lib/bundler/runtime.rb:51:in
`require'
        from
/Library/Ruby/Gems/1.8/gems/bundler-1.0.7/lib/bundler.rb:112:in
`require'
        from
/Users/arkidmitra/Documents/qorm_bzar/buyzaar/config/application.rb:7
        from
/Library/Ruby/Gems/1.8/gems/railties-3.0.3/lib/rails/commands.rb:28:in
`require'
        from
/Library/Ruby/Gems/1.8/gems/railties-3.0.3/lib/rails/commands.rb:28
        from
/Library/Ruby/Gems/1.8/gems/railties-3.0.3/lib/rails/commands.rb:27:in
`tap'
        from
/Library/Ruby/Gems/1.8/gems/railties-3.0.3/lib/rails/commands.rb:27
        from script/rails:6:in `require'
        from script/rails:6

I am using Rails 3.0.3 and Ruby 1.8.7. Also the sever seems to be
starting fine till I add

gem "authlogic-oauth2"
to the Gemfile.