Seems I'm missing some kind of library?

When I run "rake db:create --trace" in my rails directory, or if I
attempt a "bundle install" I get the same error around missing
"rubygems/format". I am new, but I am really hoping there is some way
that I can discover which package this "rubygems/format" belongs in.
I did a locate on "format" | grep gem and I didn't find any
"format.rb" files on my system. Which leads me to believe that either
"rubygems/format" is not referring to a file literally called
"format.rb", or that it is exactly the case and I am missing the
package that it comes in. Can anyone help me to debug this issue?
Thanks in advance.

rake aborted!
no such file to load -- rubygems/format
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:39:in
`gem_original_require'
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:39:in `require'
/usr/lib64/ruby/gems/1.8/gems/bundler-1.0.22/lib/bundler/source.rb:5
/usr/lib64/ruby/gems/1.8/gems/bundler-1.0.22/lib/bundler/dsl.rb:14:in
`initialize'
/usr/lib64/ruby/gems/1.8/gems/bundler-1.0.22/lib/bundler/dsl.rb:6:in
`new'
/usr/lib64/ruby/gems/1.8/gems/bundler-1.0.22/lib/bundler/dsl.rb:6:in
`evaluate'
/usr/lib64/ruby/gems/1.8/gems/bundler-1.0.22/lib/bundler/definition.rb:
17:in `build'
/usr/lib64/ruby/gems/1.8/gems/bundler-1.0.22/lib/bundler.rb:138:in
`definition'
/usr/lib64/ruby/gems/1.8/gems/bundler-1.0.22/lib/bundler.rb:126:in
`load'
/usr/lib64/ruby/gems/1.8/gems/bundler-1.0.22/lib/bundler.rb:110:in
`setup'
/usr/lib64/ruby/gems/1.8/gems/bundler-1.0.22/lib/bundler/setup.rb:7
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:104:in
`gem_original_require'
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:104:in
`require'
/home/dev/testapp/config/boot.rb:6
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:39:in
`gem_original_require'
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:39:in `require'
/home/dev/testapp/config/application.rb:1
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:39:in
`gem_original_require'
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:39:in `require'
/home/dev/testapp/Rakefile:5
/usr/lib64/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/rake_module.rb:
25:in `load'
/usr/lib64/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/rake_module.rb:
25:in `load_rakefile'
/usr/lib64/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:
501:in `raw_load_rakefile'
/usr/lib64/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:
82:in `load_rakefile'
/usr/lib64/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:
133:in `standard_exception_handling'
/usr/lib64/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:
81:in `load_rakefile'
/usr/lib64/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:
65:in `run'
/usr/lib64/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:
133:in `standard_exception_handling'
/usr/lib64/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:
63:in `run'
/usr/lib64/ruby/gems/1.8/gems/rake-0.9.2.2/bin/rake:33
/usr/bin/rake:19:in `load'
/usr/bin/rake:19

When I run "rake db:create --trace" in my rails directory, or if I
attempt a "bundle install" I get the same error around missing
"rubygems/format". I am new, but I am really hoping there is some way
that I can discover which package this "rubygems/format" belongs in.
I did a locate on "format" | grep gem and I didn't find any
"format.rb" files on my system. Which leads me to believe that either
"rubygems/format" is not referring to a file literally called
"format.rb", or that it is exactly the case and I am missing the
package that it comes in. Can anyone help me to debug this issue?
Thanks in advance.

The first thing i'd do is check the version of rubygems you're using:
http://gembundler.com/compatibility

Fred