Ruby LSAPI 1.9 + LSWS 2.2.2

Hi,

If you have been using or evaluating LiteSpeed web server + Ruby LSAPI
setup for Rails application, please make sure your are using the latest
release, Ruby LSAPI 1.9 and LSWS 2.2.2. We have been fixing a few bugs
that causes DB connection errors, incompatibilities with WEBrick/Mongrel
and ruby process management issues, currently, all bug reported has been
addressed in timely manner and there is no outstanding issues. Thank you
all who had submitted bug reports to us.

Best Regards,
George Wang

We have only problems with all Ruby LSAPI after version 1.6.

OS: Debian Sarge and Ubuntu Dapper
Ruby: 1.8.4
Rails: various, up to 1.1.6
Litespeed: currently 2.2.2

We are using rubygems (ruby-lsapi) installation.

With ruby-lsapi-1.8 there was segfaults. The current 1.9 give us 503
error after several minutes of usage. Only the 1.6 release is working
without problems on the same systems.

I'm running a free hosting site using LSWS 2.2.2 and LSAPI 1.9 - and
it works like a charm. Yet to receive a single error.

Thanks,
Pratik

/opt/lsws/logs/stderr.log

/opt/rubygems/gems/ruby-lsapi-1.9/lib/lsapi.so: warning: already
initialized constant ENV
/opt/lsws/fcgi-bin/RailsRunner.rb:11:in `replace': method
`respond_to?' called on terminated object (0x40acdd30)
(NotImplementedError)
        from /opt/lsws/fcgi-bin/RailsRunner.rb:11

Hi Stoyan Zhekov,

Can you please fill a bug report on our forum, we need to more
information to address this issue. It will be really great if we can
access your test server if there is one.

We can exchange more information off the list.

Best Regards,

George Wang

Stoyan Zhekov wrote:

Thanks Stoyan, I think I figured out what exactly causes this bug, that
because “env_copy” has been garbage collected.

The bug should be fixed in ruby-lsapi 1.10, anyone who get 503 errors,
please uninstall 1.9 and try 1.10 attached.

Or get it from
Thanks,
George Wang
Stoyan Zhekov wrote:

ruby-lsapi-1.10.tar.gz (26.3 KB)