Ruby 1.9 compatibility on Rails 2.2 currently broken

Now that the final Rails 2.2.1 release is comming, and that one of the features is to be ready for Ruby 1.9 compatibility, it might be a good idea to merge this tiny patch for boot.rb that will fix a bug on the Rails bootstrap using Ruby 1.9:

http://rails.lighthouseapp.com/projects/8994-ruby-on-rails/tickets/1176

Carlos Paramio

Jeremy's been keeping an eye on our 1.9 compatibility, and he's the
best one to pipe up with a reply. However my understanding is that
several 1.9 changes have broken 2.2 support (test related assertions
f.ex) and we'll likely be holding off till 2.3 before we ship a '1.9
friendly' release.