ROR setup on ubuntu machine

i followed this, and setup all the stuffs.
After i created a new rails application, when i create a database i got one error like
cyberpro@ubuntu:~/blog$ rake db:create
rake aborted!
Could not find a JavaScript runtime. See for a list of available runtimes.
(See full trace by running task with --trace)

Try this:

Thanks for the response. i think this question, which am going to put here, is a bad question, anyway
when i start the server
cyberpro@ubuntu:~/blog$ rails server
/home/cyberpro/.rvm/gems/ruby-1.9.2-p290/gems/rack-1.3.4/lib/rack/backports/uri/common_192.rb:53: warning: already initialized constant WFKV_
=> Booting WEBrick
=> Rails 3.1.1 application starting in development on
=> Call with -d to detach
=> Ctrl-C to shutdown server
[2011-10-12 15:15:12] INFO WEBrick 1.3.1
[2011-10-12 15:15:12] INFO ruby 1.9.2 (2011-07-09) [i686-linux]
[2011-10-12 15:15:12] INFO WEBrick::HTTPServer#start: pid=9007 port=3000
my question is, how to move to the db creation ? i mean how to stop this. can i use this Call with -d to detach
=> Ctrl-C to shutdown server
and continue…

Am sorry for asking this type of question

Couldn't disagree more. RVM actually makes like a lot easier for
beginners IMO. The install is simple and easy (just run the script)
and works perfectly fine on pretty much any version of Ubuntu.

Using RVM allows beginners to tinker with various versions of Ruby in
a non-traumatic way and keeps each project in its own gemset to avoid
version conflicts and issues with dependencies. Once installed
correctly, with wrappers in place, it works identical to native ruby
only you don't have to "sudo" so much.

It's a great place to both start and finish as a ruby developer. I run
RVM locally and in production and I advise all the newbies I help out
to do the same. Particularly on an OS X dev environment, native ruby
is a pain and RVM alleviates most of those pain points.

Work through some tutorials that will show you the basics of Rails. is good and is free to use online. Then you will
look back on the questions you are asking and not believe that you had
to ask them :slight_smile:

Also look at the Rails Guides.


If you want to stop WEBrick server then use CTRL+C (if that doesn’t work try CTRL+Z).

OR, you can open another terminal window and work there to create your database (I recommend that).


Thanks all, thanks mg1313

Advanced thanks to all, for given some important links, which help me a lot, to start the ROR from scratch. After all the set-up, I have created one page. so next i need to integrate a simple application with twitter. Simple application means when i write something in a text box and click the button, that will update into my twitter account. for that i have to use the twitter apis
for the authentication purpose, i have got the token from twitter. But i have some confusing how to use it, And also this rails basically going with MVC. so where the code will write? and so on…
I knw the MODEL is basically connection with the database, and the VIEW for the presentation. and finally the CONTROLLER have the main function part. But where will write the code for each one? If have any mistake in my understand, plz specify the issues?

also i got some link about dis


Have you worked right through some tutorials such as This will answer most of these questions.



Dan Nachbar

rvm > apt

I really like using rvm for different gemsets. When you want to test
out the latest version of rails for 1 project it makes life so much
easier. apt and rvm have declared a delicate truce on my machine. I
basically use apt for system wide packages and rvm for ruby and rails
so that I can have different versions on different projects.

I followed this link for integrate with twittter
but when i give this in console i got the error like this

client =
#<Twitter::Client:0x971a79c @adapter=:net_http, @consumer_key=nil, @consumer_secret=nil, @endpoint=“”, @format=:json, @gateway=nil, @oauth_token=nil, @oauth_token_secret=nil, @proxy=nil, @search_endpoint=“”, @user_agent=“Twitter Ruby Gem 1.7.2”, @media_endpoint=“”, @faraday_options={}>
>client.update(‘Test post from the console’)

Twitter::Unauthorized: POST 401: Could not authenticate you.
from /home/cyberpro/.rvm/gems/ruby-1.9.2-p290/gems/twitter-1.7.2/lib/faraday/response/raise_http_4xx.rb:12:in on_complete' from /home/cyberpro/.rvm/gems/ruby-1.9.2-p290/gems/faraday-0.7.5/lib/faraday/response.rb:9:in block in call’
from /home/cyberpro/.rvm/gems/ruby-1.9.2-p290/gems/faraday-0.7.5/lib/faraday/response.rb:62:in on_complete' from /home/cyberpro/.rvm/gems/ruby-1.9.2-p290/gems/faraday-0.7.5/lib/faraday/response.rb:8:in call’
from /home/cyberpro/.rvm/gems/ruby-1.9.2-p290/gems/faraday-0.7.5/lib/faraday/request/url_encoded.rb:14:in call' from /home/cyberpro/.rvm/gems/ruby-1.9.2-p290/gems/faraday-0.7.5/lib/faraday/request/multipart.rb:13:in call’
from /home/cyberpro/.rvm/gems/ruby-1.9.2-p290/gems/twitter-1.7.2/lib/faraday/request/multipart_with_file.rb:18:in call' from /home/cyberpro/.rvm/gems/ruby-1.9.2-p290/gems/faraday-0.7.5/lib/faraday/connection.rb:207:in run_request’
from /home/cyberpro/.rvm/gems/ruby-1.9.2-p290/gems/faraday-0.7.5/lib/faraday/connection.rb:94:in post' from /home/cyberpro/.rvm/gems/ruby-1.9.2-p290/gems/twitter-1.7.2/lib/twitter/request.rb:27:in request’
from /home/cyberpro/.rvm/gems/ruby-1.9.2-p290/gems/twitter-1.7.2/lib/twitter/request.rb:10:in post' from /home/cyberpro/.rvm/gems/ruby-1.9.2-p290/gems/twitter-1.7.2/lib/twitter/client/tweets.rb:45:in update’
from (irb):23
from /home/cyberpro/.rvm/gems/ruby-1.9.2-p290/gems/railties-3.1.1/lib/rails/commands/console.rb:45:in start' from /home/cyberpro/.rvm/gems/ruby-1.9.2-p290/gems/railties-3.1.1/lib/rails/commands/console.rb:8:in start’
from /home/cyberpro/.rvm/gems/ruby-1.9.2-p290/gems/railties-3.1.1/lib/rails/commands.rb:40:in <top (required)>' from script/rails:6:in require’

I suggest starting a new thread with an appropriate subject for this
question as it does not seem to be anything to do with the subject
line (ROR setup on ubuntu machine). In that way someone interested in
this subject is more likely to read the message.


i had some problem with my ubuntu, so just i changed that into 11.10, now am setting up the RoR in ubuntu following this link . But i got the wrong command error when i doing this command **
sudo aptitude install build-essential bison openssl libreadline6 libreadline6-dev curl git-core zlib1g zlib1g-dev libssl-dev libyaml-dev libsqlite3-0 libsqlite3-dev sqlite3 libxml2-dev libxslt-dev autoconf**


why like dis?, but i had done the same thing earlier on my last ubuntu with no issues.

Thank You

Which command is not found?

Did you tried Europe apt-get install instead?

Or installed aptitude via apt-get?

thank you, i forgot to change that aptitude into apt-get.

Thank you

or you can install aptitude using

sudo apt-get install aptitude

and then use it later...