ROR books seem to be out of date

/* content-free whinging deleted */

help

No one is going to be able to even confirm your suspicions without
your providing actual information.

What "texts"? What "examples"? What versions of Rails, gem, etc.
are you trying to use? What problems are you having? Saying that
some code "won't run" is a waste of everyone's time.

You seem to be complaining about the IDEs more than RoR. Give us some
details and we might be able to help you.