"rm public/index.html not recognized...."

I typed, "rm public/index.html"

Got back, "'rm is not recognized as an internal or external command,
operable program or batch file."

Bruce

Are you on a *nix system( Linux,MacOS X , BSD’s)?

If you are , have you already checked the environment variables?

If you aren’t , this is a *nix command.

It sounds like you're on Windows. When you're reading tutorials that have UNIX commands in, you'll need to use the Windows equivalent instead. 'rm' deleted files, so in the Windows command prompt you'd use 'del' instead.

The good news is that once you start writing Ruby code and using the Rails APIs, they're mostly platform-independent, so you should have less trouble with the tutorials.

Chris

Actually I took a guess at del and got back: Invalid switch -
"index.html".

But rem worked!

shouldn't the directory separator be inverted in windows?

del public\index.html

OOps! It's still there, but the rem didn't give me any kind of error
message.

have you already tried , “del public\index.html” ?

del public\index.html

If this step is proving a stumble, maybe it would be appropriate to
take some computer foundations classes before trying to learn RoR and
application development? (or if you are very experienced with a
different computer OS, can you do some sort of primer on the
differences in the basics in Windows?)

You need to "cd public" then "del index.html" windows always have
problems with path :smiley:

Thanks Jan - ran into same problem. 'del' for windows (vs. 'rm'), and
the cd to 'public' did the trick. Very helpful.

Jan V. wrote in post #1087171: