request routing plugin and subdomain share process

Hi Rails Guru,

I am using the request routing plugin to implement subdomain on my
app. To do this, I use cpanel and created bunch of subdomain, all
pointing at the same public folder under one rails app. However, when
request reaches a subdomain of my app, the rails fastcgi process
doesn't seem to use rails fastcgi process created for another
subdomain, even though all rails fastcgi process should have the same
content because it's in the same rails app. How can I configure my app
so that the fastcgi process can share among subdomains? Thanks!

Mongdar wrote:

Hi Rails Guru,

I am using the request routing plugin to implement subdomain on my
app. To do this, I use cpanel and created bunch of subdomain, all
pointing at the same public folder under one rails app. However, when
request reaches a subdomain of my app, the rails fastcgi process
doesn't seem to use rails fastcgi process created for another
subdomain, even though all rails fastcgi process should have the same
content because it's in the same rails app. How can I configure my app
so that the fastcgi process can share among subdomains? Thanks!

Your problem is not related with the request routing plugin, but with
apache not executing the dspatcher. Baybe you can post your apache
config and .htaccess file?
I did not have this problem because I don't use fcgi, but when I created
this[1] site I had some problems too with subdomains. On that page I am
using apache -> haproxy -> mongrels
So in apache I have
    ProxyPass / http://127.0.0.1:9000/
    ProxyPassReverse / http://127.0.0.1:9000/
and every request hits a mongrel and thus the app.

[1][shameless spam] http://diffuse.it

I am on shared server and don't have access to apache onfig

Mongdar wrote:

Hi Akira,

Below is my .htaccess . I pretty much used what was generated by
rails.

# General Apache options
AddHandler fastcgi-script .fcgi

cut

looks all fine to me. must be some apache config then. i think you have
to ask your hosting provider.

ic. thank you!!!