Renaming Journey and avoiding libraries with common noun names

Essentially our project has a model named Journey, the same as Rails 3.2’s new routing driver. As a consequence we can no longer upgrade from 3.1, without changing ‘journey’ throughout our project.

Why don’t you rename it to MyProject::Journey and reimplement model_name method ?

class MyProject::Journey

def self.model_name

@model_name ||= ::Journey



I am not sure if that would work perfectly but you can give it a try.

Robert Pankowecki