Rails Server Failing - No such file or directory - tmp/pids/server.pid

I apologize for my stupidity. I've been running rails on this machine
for a few months. I have upgraded to Ruby on Rails 3 to start playing
around. When running the "rails server" I get the following output.
Any help is much appreciated.

I installed Rails 3 very easily on my box at work. But here, not so
much. It's been a few hours, I can't talk in IRC - not sure why.
Getting frustrated with myself.

Thanks for any help in advance!

merrick-christensens-mac-pro:campaignarkitekt.com Merrick$ rails
server
=> Booting WEBrick
=> Rails 3.0.0.beta application starting in development on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
Exiting
/opt/local/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/server.rb:208:in
`initialize': No such file or directory - tmp/pids/server.pid
(Errno::ENOENT)
  from /opt/local/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/server.rb:
208:in `open'
  from /opt/local/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/server.rb:
208:in `write_pid'
  from /opt/local/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/server.rb:
154:in `start'
  from /opt/local/lib/ruby/gems/1.8/gems/railties-3.0.0.beta/lib/rails/
commands/server.rb:49:in `start'
  from /opt/local/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/server.rb:
83:in `start'
  from /opt/local/lib/ruby/gems/1.8/gems/railties-3.0.0.beta/lib/rails/
commands.rb:39
  from /Users/Merrick/Work/Arkitekt/Projects/Campaign Arkitekt/
campaignarkitekt.com/script/rails:10:in `require'
  from /Users/Merrick/Work/Arkitekt/Projects/Campaign Arkitekt/
campaignarkitekt.com/script/rails:10

Nobody?

No idea why it's failing, but just make the directory yourself for
now.
From rails root: mkdir temp;mkdir temp pids

Er, mkdir tmp;mkdir tmp/pids
I ran into the same issue and making these directories by hand cleared
it up just fine.

I had this problem. I deleted my app's directory and brought down the
code from scratch from GitHub. Rails server worked after that.