# Rails on Mac OS X Leopard...

**URL:** <https://discuss.rubyonrails.org/t/rails-on-mac-os-x-leopard/26391>\
**Category:** rubyonrails-talk\
**Created:** [March 16, 2008, 7:01pm UTC](https://discuss.rubyonrails.org/t/rails-on-mac-os-x-leopard/26391 "2008-03-16T19:01:27Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![nahabed](https://avatars.discourse-cdn.com/v4/letter/n/b77776/32.png) [@nahabed](https://discuss.rubyonrails.org/u/nahabed)\
**Post date:** [March 16, 2008, 7:01pm UTC](https://discuss.rubyonrails.org/t/rails-on-mac-os-x-leopard/26391/1 "2008-03-16T19:01:27Z")

</div>

A few days ago I got a new Macbook Pro (yippie!). Until now, I was using Instant Rails on Windows. I am now trying to get my rails projects to run on the MBP having copied them from Windows.

From the terminal window, I can see that Rails and Ruby are installed as advertised (--version works). For now, I am happy wth Ruby 1.8.6 and Rails 1.2.6 that are on there. HOWEVER, when I try "ruby script/ server" or "ruby script/console" I keep getting the following error.

Cannot find gem for Rails ~\>1.2.3.0: &nbsp;&nbsp;&nbsp;&nbsp;Install the missing gem with 'gem install -v=1.2.3 rails', or &nbsp;&nbsp;&nbsp;&nbsp;change environment.rb to define RAILS\_GEM\_VERSION with your desired version.

What am I missing? Isn't all the "basic" stuff preinstalled out of the box? The project I am trying to run is very simple - no fancy gems or anything. It was also built using 1.8.6

I read this [http://developer.apple.com/tools/developonrailsleopard.html](http://developer.apple.com/tools/developonrailsleopard.html) but its trying to get me to update and I'd like to stick to 1.8.6 and 1.2.6 since some of my other projects are based on that.

Thanks, Roupen N.

---

<div class="post-metadata">

**Author:** ![Peter\_De\_Berdt](https://avatars.discourse-cdn.com/v4/letter/p/53a042/32.png) [@Peter\_De\_Berdt](https://discuss.rubyonrails.org/u/Peter_De_Berdt)\
**Post date:** [March 16, 2008, 7:07pm UTC](https://discuss.rubyonrails.org/t/rails-on-mac-os-x-leopard/26391/2 "2008-03-16T19:07:46Z")

</div>

Your environment.rb states Rails 1.2.3 as the version to look for, just change it to 1.2.6 and you’re done.

Best regards

Peter De Berdt
