Rails DOM naming conventions?

When I'm making views in Rails I am using my own naming conventions for dom id's and classes:

<div id="posts" class="posts">   <div id="post_23" class="post">     <h2 id="post_23_headline" class="headline">Ruby on Rails</h2>     <p id="post_23_content" class="content">Lorem ipsum dolor sit amet.</p>   </div>   <div id="post_24 class="post">     ...   </div> </div>

I've been trying to Google a little around, trying to find an answer, but are there any official or semi-official naming conventions for id's and classes in the view out there?

Or is it more like a personal preference?

When I'm making views in Rails I am using my own naming conventions for dom id's and classes:

<div id="posts" class="posts"> <div id="post_23" class="post"> <h2 id="post_23_headline" class="headline">Ruby on Rails</h2> <p id="post_23_content" class="content">Lorem ipsum dolor sit amet.</p> </div> <div id="post_24 class="post"> ... </div> </div>

I've been trying to Google a little around, trying to find an answer, but are there any official or semi-official naming conventions for id's and classes in the view out there?

Perhaps you are looking for the dom_id, dom_class, div_for helpers ?

Fred

Frederick Cheung wrote:

� � ... � </div> </div>

I've been trying to Google a little around, trying to find an answer, but are there any official or semi-official naming conventions for id's and classes in the view out there?

Perhaps you are looking for the dom_id, dom_class, div_for helpers ?

These are not conventions. They're after all just helper methods. But it's right that they're keeping some conventions when it comes to naming id's and classes too.