Metric_fu is informing me of some nested iterators, and I was hoping to
gather some advice on how to refactor this method to make it more
correct. Hopefully this will assist me in refactoring many other
Code is here: http://pastie.org/private/kqp1kk2uk81rs8s6atag
Any thoughts on this?
Thank you in advance!