Rails autosize plugin gem not working

I’m having some issues getting Jack Moore’s autosize plugin working in Rails 4.

When I place the following script in application.html.erb, it doesn’t work. But when I place it directly in the same view as the text area, it works fine. I thought all files could see the javascript if it was placed in application.html.erb?

<script type="text/javascript" src="http://cdnjs.cloudflare.com/ajax/libs/autosize.js/1.18.4/jquery.autosize.min.js"></script>

``

Also, I can’t get the gem working. In my gemfile I have gem 'autosize', '~> 1.1.18.4', I’ve done bundle install, bundle update, gem install autosize, restarted the server, but it doesn’t work.

Is gem ‘autosize’, ‘~> 1.1.18.4’ a typo? I ask because at http://plugins.jquery.com/autosize/ that version is not listed.
Liz

Is there a reason you're not following the directions?
[quote]
Install

add gem 'autosize' to your Gemfile (and then run bundle install).

And in your application.js: //= require jquery.autosize
[/quote]

I did that with a fresh Rails 4.2 app and it worked as advertised.

How are you invoking it on your textarea and what *exactly* do you
mean by "doesn't work"? Are there JS errors in the console?