Rails application failed to start properly

I think I'm too close to this problem - and I'm guessing that the answer
is actually obvious, but I don't see it.

I have an application that's getting the error message "Rails
application failed to start properly". Everything else (all written with
rails) on the site is running, it's just one function that is not
working. I've tracked it down to the following statement in a view:

   <%= link_to('Delete', {:action => 'deleteUser', :id => u},
    :confirm => "Delete #{u.firstName} #{u.lastName}?",
    :method => :post ) %>

If this statement is in the view, the function fails. If it is not in
the view, the function works. I have further tracked it to the part of
the statement that starts with :confirm. If I end the statement at that
point, the function works.

Any suggestions?

I have encountered the same problem.

You may try running dispatch.fcgi directly in the public folder of your
rails application. And you may get something helpful.

#cd public/
#./dispatch.fcgi

In my case, I got the error log below
"ActionView::TemplateError (wrong argument type String (expected Proc))
on line #63 of unit/_search_form.rhtml:"
(I am using a submit_to_remote in #63 of unit/_search_form.rhtml)

After googling about it, I think this problem was introduced recently
and
hopefully it has been solved.

You may refer to:

http://www.bluehostforum.com/showthread.php?t=13848

I wish this helps.

Michael Satterwhite wrote:

   <%= link_to('Delete', {:action => 'deleteUser', :id => u},
    :confirm => "Delete #{u.firstName} #{u.lastName}?",
    :method => :post ) %>

<%= link_to 'Delete', {:action => 'deleteUser', :id => u}, :confirm =>
"Delete #{u.firstName} #{u.lastName}?", :method => :post %>

have you tried that?? if not work too, may be your problem is in your
"u" variable.

Reinhart
teapoci.blogspot.com
booking2heaven@yahoo.com