Rails 2.2.0 and Gettext incompatible?

Hi all,

Today I tried to upgrade one my Rails app to use version 2.2.0 of the framework. However mongrel could not start because of some incompatibility problems.

The version of gettext gem is 1.93.0

Here it is the error output:

Htis is only the top of the iceberg, render_file can be fixed by patching gettext, but the rest of gettext must largely be rewritten, since rails does not use class- instance variables(@@) anymore for thread safety reasons

therefore my guess is that the next version of gettext could take some time...

10x for the explanations.

It looks that we should continue developing with the current 2.1.2 version.

See also rails 2.2's builtin localization stuff: http://www.artweb-design.de/2008/7/18/the-ruby-on-rails-i18n-core-api

Masao Mutoh says: work is under way, new gettext will require ruby- locale to run, hopefully we can switch to 2.2 soon :smiley:

Masao Mutoh says: work is under way, new gettext will require ruby- locale to run, hopefully we can switch to 2.2 soon :smiley: