Project Server not starting. No Errors.

versions? check script\about

Eric wrote:

versions? check script\about

On Oct 18, 5:27�pm, Peter Warrick <rails-mailing-l...@andreas-s.net>

Eric,

Thanks for the reply and the help.. This is what script/about reported..

About your application's environment
Ruby version 1.8.7 (universal-darwin10.0)
RubyGems version 1.3.1
Rails version 1.2.3
Active Record version 1.15.3
Action Pack version 1.13.3
Action Web Service version 1.2.3
Action Mailer version 1.3.3
Active Support version 1.4.2
Application root /Users/peter/Development/RadRails
Workspace/rails_space
Environment development
Database adapter postgresql

Peter

The app was written for an older version of rails, do you have those
versions installed?

-eric

Hi Peter Warrick

   Have you properly setup database? Seems like you have not given
username and/or password in database.yml

Sijo

Sijo k g wrote:

Hi Peter Warrick

   Have you properly setup database? Seems like you have not given
username and/or password in database.yml

Sijo

Sijo,

Thanks for the reply. The DB is working properly. It was working earlier
today no problem. As I stated above, I copied over my project to my
laptop with the hostname of the db set to the IP of my original machine.
Everything works just fine.

It does seem likes it's waiting to do something but is stuck. I hit
CTRL-C and it then says it's started up the server. But its not actually
running since nothing shows up in netstat and when I try to connect to
it via a browser it of course doesn't work.

I'm baffled by this one.

Peter

Ok this was a tough one. But I have FIXED it.

Turns out this is a bug in mongrel. Normally I would not have believed
this as this was working just fine before and then suddenly stopped.
Admittedly I can't remember what little I did to mess it up but I'm
thinking a gem got messed up or a bad one got installed.

Good stuff. Something else that may prove problematic: ruby 1.8.7 came
out way after rails 1.2.3 and only later versions of rails were marked
as being compatible with it (from memory 2.1.something) - you may get
odd errors further down the line

Fred