Problem while installing passenger for apache

Hi,

I am trying to install passenger 3.0 for apache2 on Ubuntu 10.10.

It says that I need to install libopenssl-ruby.

But when I did 'sudo apt-get install libopenssl-ruby', I got the
following error.

Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libruby' instead of 'libopenssl-ruby'
libruby is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 21 not upgraded.

How do I install libopenssl-ruby?

Thanks.

Sam

Try this Thread here for answers:

http://ubuntuforums.org/showthread.php?t=910285

you nedd to recompile the ruby ssl module.

if you have installed ruby with rvm:
cd $HOME
cd .rvm/src/ruby-1.9.2-p0/ext/openssl
ruby extconf.rb
make
make install

Solrac Caritas wrote in post #955372:

you nedd to recompile the ruby ssl module.

if you have installed ruby with rvm:
cd $HOME
cd .rvm/src/ruby-1.9.2-p0/ext/openssl
ruby extconf.rb
make
make install

Thanks - found this after posting similar question for nginx!

Solrac Caritas wrote in post #955372:

you nedd to recompile the ruby ssl module.

if you have installed ruby with rvm:
cd $HOME
cd .rvm/src/ruby-1.9.2-p0/ext/openssl
ruby extconf.rb
make
make install

Thanks - must have crossed in the post!