problem running phusion passenger on os x 10.6

Hi,
I am trying to update passenger for 10.6, and I am getting an error
relating to fastthread... passenger thinks fastthread is missing.
Here' the apache error log output:

Hi, did you rebuild all native gems after installing Snow Leopard and

their associated development tools? If not, then you should read the

following:

http://weblog.rubyonrails.org/2009/8/30/upgrading-to-snow-leopard

BTW, I have been using Snow Leopard and Passenger without any

issues.

Good luck,

-Conrad

Thanks for the idea. I had already updated everything. The problem
turned out to be that for some reason, my installation of ruby was
still at 1.8.6 instead of 1.8.7 that is supposed to be installed with
snow leopard. in my case it wasn't, not sure why, but the passenger
install script only requires the fastthread library in ruby versions
lower than 1.8.7. So I installed ruby 1.8.7 from source, and now
everything seems to be working.

thanks,
sean