Plugins with /trunk

So, can someone please apply this. This would save us like one
bug-report a week! All of my plugins use tags, trunk, and branching
because they are fairly complex. And the fact that using well-tested
methods for revision control means that you break ./script/plugin
install is a bit of a tragedy.

Can someone please apply this already?

http://dev.rubyonrails.org/ticket/8188

I will ILY forever and ever!

-hampton.

I went ahead and added the “verified” keyword as described in bullet 5.2 on http://dev.rubyonrails.org/wiki.

Plugins with trunk/ already work for some time now:

http://dev.rubyonrails.org/browser/trunk/railties/lib/commands/plugin.rb?rev=7585#L261

However, it still doesn’t behave with tags and branches. +1 for a more complete solution that we currently have

Oops I spoke too soon - it worked for me because I was using svn:externals, and this is the only method that actually uses the “guessed” name.