Please check out my site.... Some cool work with associations, scope and fields_for..

Rails 3.0 is long obsolete and, I believe, no longer receives even
security updates, it should not be used for production applications.

Colin