passenger and 2.2.2

For some reason I can't get passenger to run a 2.2.2 rails app. The
same app runs fine from script/server.
Under passenger I get:

Framework that failed to load:
Rails framework version 2.2.2
Error message:
RubyGem version error: activesupport(1.4.2 not = 2.2.2)
Exception class:
Gem::LoadError
Backtrace:

This is with a clean test app generated via:
rails _2.2.2_ testapp

The strange thing is that I have an app with a frozen 2.2.2 and it
runs fine.

It seems youre activesupport gem is not up-to-date, or at least passenger doesn't see version 2.2.2 but version 1.4.2. The app with the frozen 2.2.2 will also have activesupport 2.2.2 frozne in there too, which allows it to run fine.

Regards,

Felix

Hmm ok.
The wierdness continues with this:
$gem list activesup
activesupport (2.3.2, 2.2.2, 1.4.4, 1.4.2)
$ sudo gem uninstall activesupport -v 1.4.2
ERROR: While executing gem ... (Gem::InstallError)
    Unknown gem activesupport = 1.4.2

$ ls /Library/Ruby/Gems/1.8/gems/activesup*
/Library/Ruby/Gems/1.8/gems/activesupport-2.1.0:
/Library/Ruby/Gems/1.8/gems/activesupport-2.1.2:
/Library/Ruby/Gems/1.8/gems/activesupport-2.3.2:

what can I do to resolve this? Reinstalling 2.2.2 doesn't seem to have
done anything to help