>= option in config.gem

Well, you tell it to use a version higher OR equal to 1.2.1 ... If you
want it to use only 1.2.1 it should say:

config.gem 'gemname', :version => '1.2.1'

Hope this helps!

Kind regards,
Jaap Haagmans
w. http://www.relywebsolutions.nl